-
misaka00251 authoredmisaka00251 authored
rocblas.spec 5.80 KiB
%global upstreamname rocBLAS
%global rocm_release 6.2
%global rocm_patch 2
%global rocm_version %{rocm_release}.%{rocm_patch}
%global toolchain rocm
# hipcc does not support some clang flags
%global build_cxxflags %(echo %{optflags} | sed -e 's/-fstack-protector-strong/-Xarch_host -fstack-protector-strong/' -e 's/-fcf-protection/-Xarch_host -fcf-protection/')
# $gpu will be evaluated in the loops below
%global _vpath_builddir %{_vendor}-%{_target_os}-build-${gpu}
%bcond_with debug
%if %{with debug}
%global build_type DEBUG
%else
%global build_type RELEASE
%endif
%bcond_without compress
%if %{with compress}
%global build_compress ON
%else
%global build_compress OFF
%endif
%bcond_with test
%if %{with test}
%global build_test ON
%global __brp_check_rpaths %{nil}
%else
%global build_test OFF
%endif
# Tensile blocks general enablement of rocBLAS.
%bcond_with tensile
%if %{with tensile}
%global build_tensile ON
%else
%global build_tensile OFF
%endif
# Why Build ID is 8 bytes
%global buildid 1
Name: rocblas
Version: %{rocm_version}
Release: 1
Summary: BLAS implementation for ROCm
Url: https://github.com/ROCmSoftwarePlatform/%{upstreamname}
License: MIT AND BSD-3-Clause
Source0: %{url}/archive/refs/tags/rocm-%{rocm_version}.tar.gz#/%{upstreamname}-%{rocm_version}.tar.gz
Patch0: 0001-fixup-install-of-tensile-output.patch
Patch1: 0001-add-gfx1103-support-for-rocBLAS.patch
Patch2: 0001-offload-compress-option.patch
Patch1000: Fix-build-on-riscv64.patch
BuildRequires: cmake
BuildRequires: git
BuildRequires: ninja-build
BuildRequires: rocm-cmake
BuildRequires: rocm-comgr-devel
BuildRequires: rocm-hip rocm-hip-devel
BuildRequires: rocm-runtime-devel
BuildRequires: rocm-rpm-macros
BuildRequires: rocm-rpm-macros-modules
%if %{with tensile}
BuildRequires: msgpack-devel
BuildRequires: python3-tensile
%endif
%if %{with test}
BuildRequires: gtest-devel
BuildRequires: blas-devel
BuildRequires: libomp-devel
BuildRequires: python3-pyyaml
BuildRequires: rocminfo
BuildRequires: rocm-smi-devel
%endif
#Use compat if LLVM is not latest, 1 is enable
%global compat_build 1
%global maj_ver 18
%if %{compat_build}
BuildRequires: llvm%{maj_ver}-devel
BuildRequires: llvm%{maj_ver}-test
BuildRequires: llvm%{maj_ver}-cmake-utils
BuildRequires: llvm%{maj_ver}-libs
BuildRequires: lld%{maj_ver}
BuildRequires: lld%{maj_ver}-devel
BuildRequires: clang%{maj_ver}-devel
BuildRequires: clang%{maj_ver}-libs
BuildRequires: clang%{maj_ver}-tools-extra
%else
BuildRequires: llvm-devel = %{version}
BuildRequires: llvm-test = %{version}
BuildRequires: llvm-cmake-utils = %{version}
%endif
Requires: rocm-rpm-macros-modules
ExclusiveArch: x86_64 riscv64
%description
rocBLAS is the AMD library for Basic Linear Algebra Subprograms
(BLAS) on the ROCm platform. It is implemented in the HIP
programming language and optimized for AMD GPUs.
%package devel
Summary: Libraries and headers for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
%{summary}
%if %{with test}
%package test
Summary: Tests for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description test
%{summary}
%endif
%prep
%autosetup -p1 -n %{upstreamname}-rocm-%{version}
sed -i -e 's@set( BLAS_LIBRARY "blas" )@set( BLAS_LIBRARY "cblas" )@' clients/CMakeLists.txt
sed -i -e 's@target_link_libraries( rocblas-test PRIVATE ${BLAS_LIBRARY} ${GTEST_BOTH_LIBRARIES} roc::rocblas )@target_link_libraries( rocblas-test PRIVATE cblas ${GTEST_BOTH_LIBRARIES} roc::rocblas )@' clients/gtest/CMakeLists.txt
%build
# With compat llvm the system clang is wrong
CLANG_PATH=`hipconfig --hipclangpath`
export TENSILE_ROCM_ASSEMBLER_PATH=${CLANG_PATH}/clang++
export TENSILE_ROCM_OFFLOAD_BUNDLER_PATH=${CLANG_PATH}/clang-offload-bundler
# Work around problem with koji's ld
export HIPCC_LINK_FLAGS_APPEND=-fuse-ld=lld
for gpu in %{rocm_gpu_list}
do
module load rocm/$gpu
mkdir %{_target_platform}
pushd %{_target_platform}
%cmake .. -G Ninja \
-DCMAKE_BUILD_TYPE=%{build_type} \
-DCMAKE_SKIP_RPATH=ON \
-DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF \
-DROCM_SYMLINK_LIBS=OFF \
-DHIP_PLATFORM=amd \
-DAMDGPU_TARGETS=${ROCM_GPUS} \
-DCMAKE_INSTALL_LIBDIR=$ROCM_LIB \
-DCMAKE_INSTALL_BINDIR=$ROCM_BIN \
%if %{compat_build}
-DCMAKE_CXX_FLAGS="--rocm-device-lib-path=%{_prefix}/lib/clang/%{maj_ver}/amdgcn/bitcode" \
%endif
-DBUILD_CLIENTS_BENCHMARKS=%{build_test} \
-DBUILD_CLIENTS_TESTS=%{build_test} \
-DBUILD_WITH_TENSILE=%{build_tensile} \
%if %{buildid}
-DCMAKE_SHARED_LINKER_FLAGS="-Wl,--build-id=sha1" \
%endif
-DBUILD_WITH_PIP=OFF
popd
cmake --build %{_target_platform} %{?_smp_mflags} --verbose
module purge
done
%install
for gpu in %{rocm_gpu_list}
do
DESTDIR=%{buildroot} cmake --install %{_target_platform}
done
echo s@%{buildroot}@@ > br.sed
find %{buildroot}%{_libdir} -name '*.so.*.[0-9]' | sed -f br.sed > %{name}.files
find %{buildroot}%{_libdir} -name '*.so.[0-9]' | sed -f br.sed >> %{name}.files
find %{buildroot}%{_libdir} -name 'library' | sed -f br.sed >> %{name}.files
find %{buildroot}%{_libdir} -name '*.so' | sed -f br.sed > %{name}.devel
find %{buildroot}%{_libdir} -name '*.cmake' | sed -f br.sed >> %{name}.devel
find %{buildroot} -name 'rocblas-*' | sed -f br.sed > %{name}.test
find %{buildroot} -name 'rocblas_*' | sed -f br.sed >> %{name}.test
%files -f %{name}.files
%license LICENSE.md
%exclude %{_docdir}/%{name}/LICENSE.md
%files devel -f %{name}.devel
%doc README.md
%{_includedir}/%{name}
%if %{with test}
%files test -f %{name}.test
%endif
%changelog
* Mon Oct 21 2024 misaka00251 <liuxin@iscas.ac.cn> - 6.2.2-1
- Update to 6.2.2
* Fri Sep 20 2024 misaka00251 <liuxin@iscas.ac.cn> - 6.2.0-1
- Init package